New tuner and anyone got a crappy AGP video card?

I slotted a new tuner card into my MythTV backend last night. This time it was a KWorld "Dual Hybrid" from Dick Smith Powerhouse. Once again it's an SAA7134-based card, so it Just Works. Nice to have two cards in there.

I spent some time trying to get one of the analogue tuners to work. They work well for vision but I can't seem to get the audio to work, whether I use saa7134-osss or saa7134-alsa. My reading of the various wikis suggest you don't need to route the audio through the supplied cable into your soundcard, and the card is turning up as an ALSA/OSS device:

arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: I82801BAICH2 [Intel 82801BA-ICH2], device 0: Intel ICH [Intel
82801BA-ICH2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: I82801BAICH2 [Intel 82801BA-ICH2], device 1: Intel ICH - MIC ADC [Intel 82801BA-ICH2 - MIC ADC]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: SAA7134 [SAA7134], device 0: SAA7134 PCM [SAA7134 PCM]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: SAA7134_1 [SAA7134], device 0: SAA7134 PCM [SAA7134 PCM]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Also, does anyone have a crappy, low-end and, importantly, thin AGP video card? The one in there at the moment (a very high-end IBM GXT6000P) takes up the AGP slot and two PCI slots! I'd be willing to swap for the GXT6000P (though you'll need AGP Pro, I think) or a few beers to anyone who has a cheapo card. The machine doesn't need a video card but it's always handy when something goes wrong.